DoubleCAD XT v5 has released

Recent Posts

Pages: [1] 2 3 ... 10
Need Help? Problems - Solutions / "DOUBLE LINE" & "MULTILINE" ERROR
« Last post by Devine1 on May 14, 2018, 05:17:28 AM »
I've noticed for a while now that the "Double Line" and "Multiline" tools have a strange error in that they do not snap perfectly and if one holds the 'shift' key, the lines don't draw perfectly horizontally or vertically. EXAMPLE:- If I try draw a "Double Line" over an existing single "Line" by snapping to endpoints, the "Double Line" is never perfectly parallel to the single "Line". It can be a little longer or shorter than the single line AND it's angle will not be identical. It appears to be snapping to multiples of a set length and/or angle - almost as if grid snap is active (which it's not). If I enter my own set length and angle then it draws perfectly. The single "Line" tool works beautifully. Problem only exists with "Double Line" and "Multiline". Any fixes / suggestions?
DoubleCAD XT Discussion / Toggle into screen versions
« Last post by GiulioT on December 20, 2017, 07:16:00 AM »
My question is: How do I switch from the old display version, to the latest XT5 release display mode?

I do explain my problem: It happened to me that having DoubleCad already installed on my desktop PC, in the display mode of the new version of XT5, when installing DoubleCad on my lap top, I made a mistake choosing the ancient display version on the proper window that appear one time only in opening. Now I would like to know how to move from one display mode to another, to unify my way of working, that now is a little bit hard
Many thanks
GiulioT (Italy)
General Discussion / Multi text; issues with editing
« Last post by jammacbeth on October 23, 2017, 04:54:12 AM »
I consistently have issues with multi text editing; my cursor will just stay in one place and blink but I cannot move it to edit. Perhaps the issue has something to do with conversion of turbo cad into DWG files. We have Turbo Cad Lite Pro 6.0; we consistently have to convert our drawings into DWG for interoffice purposes. It seems that my text is always converted into Multi text when I save as DWG file and then when I re-open in Turbo Cad I always have this problem with editing the text. ITS MADDENING! Anyone able to help?

Thank you.
TurboCAD LTE Discussion / Re: Loading Files From DoubleCAD
« Last post by Pinglory on October 05, 2017, 01:17:21 AM »
I know I'm not very smart. So come to ask for knowledge from all of you.
Need Help? Problems - Solutions / Re: Blocks in .dxf files are empty
« Last post by Kent on September 18, 2017, 01:45:12 PM »
Problem solved - I did not have Layer 0 visible.

I have eighteen Layers, and twelve Blocks in the drawing.  On start-up, I normally hide all layers and then select the layers I need for the current session.  It is six months since I last used DoubleCAD, so my knowledge of it has got rusty.

I had forgotten that all Blocks are created in Layer 0, and the original cannot be moved from this layer  Because this layer was not visible, then when each Block was opened, nothing appeared in the window.  If only Layer 0 could be renamed to Layer "0 Blocks", I would probably have saved about three days spent trying to get my drawing to work.

I vaguely remember that there is a reason that the original Blocks can only exist in Layer 0 - something to do with being able to set their attributes By Layer when they are referenced into the drawing, I think.  But it was all so complex that I have forgotten the details now.

I see that Brian Carter includes the warning "Layer 0 should always be left visible, or blocks will instantly "disappear." in the TurboCAD/DoubleCAD Manual/ Inserting a block.  However, this is the last place I would think of looking when the error message "Block instance is empty or invisible and cannot be inserted." appears.  It is the Layer that is invisible, not the "Block instance", so it would be helpful if the message read "Block instance is empty, or its layer (Layer 0) is not visible, and therefore it cannot be inserted."
Need Help? Problems - Solutions / Blocks in .dxf files are empty
« Last post by Kent on September 15, 2017, 03:59:11 PM »
If a drawing is saved as a .dxf file, is it possible to get the Blocks to behave normally?  i.e. when EC (Edit Content) is clicked for a selected block, that the drawing of that block will be opened, rather than just an empty window..  If I try to insert a block, I get the error message "Block instance is empty or invisible and cannot be inserted.  Make sure the object is entered in the system registry."
DoubleCAD XT Discussion / Re: Display 3D in double cad XT?
« Last post by viess on August 17, 2017, 12:15:46 AM »
XT also allows for thickness.
No, my version of XT 5.0 (build 30.2), doesn't shows any 3D properties for thickness. I remember in older versions it was possible, but in newer it looks that 3D is completely left out.
TurboCAD LTE Discussion / Drawing lines
« Last post by froneck on June 28, 2017, 06:28:39 AM »
I don't know why but both version 3 and 8 on an XP computer that's not connected to the net stopped allowing me to draw lines by entering the draw to location. Clicking will work. If I draw 2 circles I can use snap and click that location such as center to center, center to quadrant. Yet nothing will work if something like @1.000,1.000 is entered. However all was working fine a bit ago. Tried shutting the computer down a few times and reload TurboCad LTE but with the same results. Any suggestion on what I can do?
TurboCAD LTE Discussion / Re: text not showing up when i save to PDF
« Last post by jammacbeth on June 27, 2017, 05:51:06 AM »
when I chose the print to PDF option everything worked out ok. For some reason when I choose the save file as PDF option I have issues with text not showing up. This is normally how I do it and I mostly have success. This is the first time I chose the print to PDF option; perhaps I will stick with this method and see how it goes.

At any rate thank you. No need for any replies; unless of course you have some info to enlighten me. I do hate not knowing why something does or does not work.
TurboCAD LTE Discussion / text not showing up when i save to PDF
« Last post by jammacbeth on June 27, 2017, 05:22:22 AM »
 create the view; go to paper space and create the view port; select the created view and bam it shows up and looks fine. I save as a PDF and sometimes everything is fine and sometimes I have text that doesn't show up. Don't get it. Currently I have a drawing where I have an inserted image which I have drawn a few lines and some text on. When I save to PDF only one set of text is showing up. Any ideas or help?????
Pages: [1] 2 3 ... 10