Register
 
DoubleCAD XT v5 has released

SEKE and Customized keyboard changes
Read 1386 times
* November 30, 2013, 06:41:20 PM
Growing up in ACAD I learned e for erase and ex for extend - and so.  I happily customised the keyboard commands in various DCAD versions but the upgrade to v5 there seemed to be a change to only one letter to describe the command (SEKEs I assume) - e can be used for erase but I can't use ex (typing the first e started the erase command). 

Not seeing a workaround for this feature I started learning the new way usine e for erase and learning x for extend - only to find one day it had reverted to the old acad way.  No worries: "adapt and conquer", eh?  I swapped back, but just now, in the same session - no saves, no reboot, no crashes - it swapped from one to the other and back again. 

Frustrating of course.

Thoughts or advice?    I did find Brians' advice to back up the Customisation file through "Options tab in the customize dialog (Tools | Customize)" and further advice in that post about the def1024acstd.cfg file.  I will play with these for a while.
 

Logged


December 02, 2013, 07:28:17 AM
#1
It sounds like your Built-in folder may have a corrupted file - Search the forum for the procedure to delete the file so that it can be rebuilt automatically.

You can specify the key sequences E, EX etc. under the Aliases - go to Tools | Customize and then go to the Aliases tab to customize these settings.

Logged


* December 06, 2013, 06:21:35 PM
#2
Thanks Brian.   - I think I figured it out though.

- The single entry keyboard execution method is "active" if the command line is not active. 

- The multi keystroke and enter execution method is active if the command line is active

Unfortunately that means I need to look at the command line to see which method has precedence every time I use a keyboard command. Or for every keyboard command positively select which method - click "Select" and then either the dwg background or the command line as desired.  A bit tedious given the great speed advantage of keyboard commands. 

Question  - - - - Is there a way to force one way or the other only (you may be able to guess my preference) so that I don't need to check/select?

Man.  This really explains much of my earlier frustration as to why my commands were not working as expected.  I assumed that I mistyped but couldn't explain why it worked so well in acad.  At least the mystery is explained. 

Thinking broadly the SEKE method once learned is faster than the multi key method.  but it limits the number of shortcut keys so that if you select c for copy, you have to select another unrelated key -say i for example - for circle.  The negative side is that i doesn't relate mentally to circle.  My preference would be multi-key entries using the spacebar to enter and activate.  Of course, I am an old dog and this is a new trick.

Logged


December 09, 2013, 09:26:26 AM
#3
Sorry no, it cannot be forced. The issue is that if the command line is active it takes control of keyed input - so single keys are ignored - that is why the ALT key is necessary.
As you probably know already, if you go to Tools/customize you can specify the quick keys under the Keyboard tab and the command line operations under the Commands tab

Logged