DoubleCAD XT v5 has released

LET'S EXPLORE TurboCAD LTE version 5 -- in DETAIL
Read 3244 times
* October 03, 2012, 07:50:19 PM
I purchased TC LTE version 4 last year.  This year, I tried the new version 5 and was impressed.  In future posts, I would like to share my thoughts with other TC LTE users.

FWIW, I use Sketchup 8, PRO for 3D work.  I do think that there is a need for a solid 2D program and I feel that TC LTE is that program.

I'd appreciate hearing from other TC LTE 5 users -- experiences, tips and tricks, glitches, UI, bugs, etc.



* October 05, 2012, 09:17:20 AM
I am running TC LTE Version 5 (64-bit) on the following PC: Intel Quad-4 I5 CPU with 4 gb of RAM, NVIDIA GeForce 9500 GT graphic card with 1 gb of RAM, Windows 7 Professional 64-bit OS.  My mouse is a Logitech optical.  The systems runs TC LTE Version 4 (32-bit) without any of the issues I am beginning to encounter with LTE Version 5, 64-bit.

ISSUE #1 -- REPEAT and RECENT Commands:  When you right-click the mouse, the pop-up menu includes two commands that don't work:  The REPEAT command and the RECENT command.  For example, after you draw an object, and exit the command, you should be able to right click and select REPEAT to invoke the last command used.  Instead, it defaults to SELECT OBJECT -- not the last command prompt.  This is frustrating, as it applies to ALL drawing commands.

Could this bug be hardware related?  No!  I still have TC LTE Version 4 (32-bit) installed on my PC and both the REPEAT and RECENT commands work as they should.

I have sent bug reports to TC regarding these two issues.

I will be adding other bugs and comments to this string of posts as they are encountered. 

« Last Edit: October 06, 2012, 01:40:41 PM by Louisaz »


* October 06, 2012, 06:38:34 AM

When attempting to draw a line perpendicular to the surface of a circle, there is NO problem -- IF your are OUTSIDE of the circle.  However, If you are INSIDE of the circle, with the SNAP to perpendicular and SNAP to intersection turned ON, the line you are drawing will not find the circumference of the circle -- if you begin the line at the center of the circle

I have tried this numerous times using the center of the circle as the starting point of the line, in which case the radial approaching the circle is ALWAYS perpendicular to the circle! 

Again:  If you're outside the circle, no problem.  If you're inside the circle attempting to draw a radial from the center of the circle to the circle, PROBLEM!  The TANGENT command works perfectly.

So...what's the answer?
« Last Edit: October 06, 2012, 06:43:25 AM by Louisaz »