DoubleCAD XT v5 has released

File corruption masquerading as Mouse Wheel Zoom origin error
Read 2103 times
* October 02, 2011, 02:45:57 PM
Help request: How can I "purge" a document to remove corruption/conflict/whatever it is causing the file to misbehave.

Symptoms:  In model space the scroll bars are locked on centre of drawing extents.  Mouse wheel zoom is fixed on that centre point whereas it used to zoom on the cursor.  Other view commands work.

Tried: Resetting profile (done that several times before!) resetting every zoom command I could find in the multitude of menu entries for settings, changing Logitech M705 mouse controls.  Then, I tried an old version of the same drawing (past corrupted files = caution) and "Lo, Behold", they zoom as before.

Conclusion: About my 5th corrupted file in 2 years and two or three hours to correct.  Very :'( 


* October 02, 2011, 11:32:48 PM
You can try with folder Built in - see post


* October 03, 2011, 01:49:20 AM
Thanks for suggesting that, Marek.  That is what I mistakenly called Resetting my profile.  Not sure if I led anyone astray with that term.  I was at a low point when I typed it and perhaps less than careful in using the term.

Deleting the Built-in has helped me out a couple of times before (I found three backups I created from previous recovery attempts when I did it this time!) so am familiar with that process; I have resetting my personal settings after a "reset" from scratch down pat. 

Cheers anyway.  I am in the process of re-doing the work now and enjoying the pure drafting process of duplicating the previous "what if this, what if that" of the design process.  Ending up with a cleaner drawing as a result, so all's well that ends well.


* May 01, 2014, 04:41:45 AM
Now with DCad5

Or rather it happened again.  What I want to note for future readers is I believe it occurred after I accidentally stretched a line to "infinity". 

First symptom was that the drawing would not zoom with the middle mouse button (MMB) wheel.  I then tried zoom extents and found the long line.  I deleted the line and could now use the MMB, but my scroll bars are again locked in position and the Dynamic Pan won't work.  Even if I vector pan, when I try MMB Dynamic pan or wheel zoom, it re-centres.

Will abandon this one and Ctrl-C to a blank drawing as per advice from another post for similar issue.