Register
 
DoubleCAD XT v5 has released

Please no ORTHO when selecting a base point
Read 6023 times
* July 19, 2010, 07:02:46 PM
I'm not sure about others but having ORTHO effect base point selection during move, copy, scale... just annoys the heck out of me. I want the point I clicked to be the base point, not the point off in space that is orthogonal to it. If XT is asking for a base point, I wished it would ignore ORTHO until after the base point is selected.

Is it just me or does anyone else feel the same?

Bill

Logged


July 20, 2010, 06:44:35 AM
#1
Not sure, "most" times I would want it off, so I almost always have ortho off when drawing, however, it should be "possible" to set a base point using ortho.

Maybe it could default to off, and one would have to specifically hit F8 or hold down a key while selecting a point to set an ortho base point.

Logged


July 20, 2010, 08:59:29 AM
#2
Why not just have the snap under the cursor (snap aperture) take priority like it is suppose to?

Logged
Cheers
~Nick

Home-Dell T3400 Quad Core Q6600 OC'd 3 GHz., 8 GB RAM, Radeon HD 3870, Windows 7 x64
ACAD 2012, DoubleCAD XT Pro v3, Alibre 2012 Expert, 123D


July 20, 2010, 09:43:58 AM
#3
Why not just have the snap under the cursor (snap aperture) take priority like it is suppose to?

I think because you might be wanting to do an ortho extending to the vertical or horizontal projection of a snap point???

Logged


July 20, 2010, 11:22:35 AM
#4
But we are talking about selecting a base point.  What would you snap to, an infinite horizontal or vertical extension?  If you wanted an intersection of the ortho projection you would
  • 1) hover to obtain ortho projections
  • 2) move mouse to the ortho intersection desired
  • 3) obtain snap point
    • 4) click

    not stay over the initial point.  Am I wrong?

Logged
Cheers
~Nick

Home-Dell T3400 Quad Core Q6600 OC'd 3 GHz., 8 GB RAM, Radeon HD 3870, Windows 7 x64
ACAD 2012, DoubleCAD XT Pro v3, Alibre 2012 Expert, 123D


July 20, 2010, 03:34:32 PM
#5
Basically you want Snap to override Ortho right?  (ala AutoCAD style...)

i.e. if I'm drawing a line with Ortho On and Snap to a intersection that is not orthogonal to the the line i'm drawing, it should snap to the intersection and not the orthogonal extension correct? 


Logged


July 20, 2010, 07:53:01 PM
#6
OK, but only for setting base points, surely not when drawing ortho lines.

Then it should always set a point at the ortho projection of the snapped point.

Logged


July 20, 2010, 08:43:02 PM
#7
I'm with Bill on this.  During base point selection ortho should be ignored.  To select a corner of a rectangle and instead get a midpoint along an ortho is almost utterly useless.  I never noticed before because I rarely, if ever use ortho and instead rely on polar extensions.

Logged
Cheers
~Nick

Home-Dell T3400 Quad Core Q6600 OC'd 3 GHz., 8 GB RAM, Radeon HD 3870, Windows 7 x64
ACAD 2012, DoubleCAD XT Pro v3, Alibre 2012 Expert, 123D


July 20, 2010, 09:58:22 PM
#8
Ok.  thanks for the clarification and preference.

Logged


July 21, 2010, 10:13:14 AM
#9
I also find the ortho snapping to the base point a bit annoying because for me it is unintuitive.  Most of the time the base points are a bit meaningless (for instance when selecting lots of things).  It isn't hard to work around, but I usually don't notice it until too late.

Logged


* August 13, 2010, 12:34:18 AM
#10
It is a pain in the you know where.

It (Ortho) seems to default to be on for every command, I feel that the snap should over-ride on every command, when moving copying even drawing a line if I want endpoint I'm not getting it, grrrr.

DoubleCAD is still great mind ;)

Logged


August 13, 2010, 09:19:19 AM
#11
You should be able to turn ortho off.
Right Click the SNAP button at the bottom of the scrren and from the dialog de-select Ortho mode.

The keyboard shortcut for this is F8 or Shift + O, depending upon your customized settings.

Logged


* August 15, 2010, 07:24:02 AM
#12
Turning Ortho on and off is generally not a problem, knowing what state it is in and when it must be off is problematic. Most of the work I do is with ortho on, drawing straight lines on the X or Y axis, moving or copying entities along the X or Y axis... But when it comes to selecting a base point, I have to turn ortho off to select the base point, then immediately back on to finish the move or copy command. Having to mash on the F8 key twice during every move or copy is very cumbersome for me.

Bill

Logged


August 16, 2010, 08:56:06 AM
#13
Got it.

Logged


* March 27, 2011, 08:24:15 PM
#14
I do agree with rossi_mac  as well that DoubleCAD is still great mind :). So keep it up!

Logged