Register
 
DoubleCAD XT v5 has released

Help! Can't select objects!!
Read 17180 times
* May 03, 2010, 10:39:09 AM
Hello,
I'm not sure what has happened, but I can no longer select objects within my drawing. I can draw lines, offset, fillet, etc., but I can't erase or select anything.....What's happening???
Brewmaster

Logged


May 03, 2010, 02:49:28 PM
#1
Hi Brewmaster,

You might want to verify that the objects you are trying to select are not on a locked layer (see image)


Logged


* May 03, 2010, 09:48:29 PM
#2
Hello Doug,
I double checked the DWG....not in a locked layer. My computer (laptop) has been to sleep and has resumed, and now, selection is possible....but, any drawing changes are failing to save with an unknown error and DoubleCAD crashes. An earlier version of the drawing works, so I'm re-drawing my layout. I guess the drawing somehow got corrupted....
Laptop is Windows 7 and I'm using the XT pro 2 trial version.
Thanks
Brewmaster

Logged


* July 23, 2010, 12:13:04 PM
#3
Same thing with me, all of a sudden my drawing froze and I can't select entities to modify, edit, erase, etc. All my layers are visible and unlocked.

I opened a different drawing and it worked.

I downloaded DoubleCAD two days ago and I'd like to know what is happening, because I can't invest hours on end to see my drawings freeze at random, making me losing all my work so far.

Is this a bug or can it be some problem with my configuration?

Logged


July 23, 2010, 12:44:42 PM
#4
Could you try saving the drawing you are having problems with in the .2CD format, close and then reopen the file?  If that works, save back to .DWG.  If you are still having problem, please email the drawing and we'll take a look.

Sorry for the problems you are having, but we'll get it going.

Thanks.
« Last Edit: July 23, 2010, 12:54:27 PM by Doug »

Logged


* July 23, 2010, 01:17:34 PM
#5
I was going to say that I had saved the drawing as a DXF file and reopened this, but still I can't get it to work as it did. And no, saving as DWG and opening this still doesn't work.

The drawing froze as I was working on it, it was not a matter of saving it and reopening later and finding it was frozen. It froze while I was working on it.

To what address should I send the drawing, if you please?

I do appreciate very much your support, for I am starting to like DoubleCAD :) I'm sure you'll find a solution!

Logged


July 23, 2010, 01:40:33 PM
#6
Just sent you an email, so just reply and attach the drawing and we'll take a look at it.

Thanks.

Logged


* July 23, 2010, 01:59:57 PM
#7
Had to send the file twice because
Quote
Hi. This is the qmail-send program at yahoo.com.
I'm afraid I wasn't able to deliver your message to the following addresses.
This is a permanent error; I've given up. Sorry it didn't work out.
 
;)

In the meantime I'll keep working on another drawing.

Thanks in advance and have a nice weekend!


Logged


July 23, 2010, 08:54:59 PM
#8
Hello,

I received the file.  All your layers were set to "Locked", so all you need to do is remove the Check for each layer in the locked layers column.  See image.

Thanks.


Logged


* July 23, 2010, 10:12:49 PM
#9
I saw your email. This was a most basic newbie error of mine!

Thank you very much for your patience and for the professional way support was provided.

I'll be more careful the next time, and will surely stick to DoubleCAD :)

Logged


* July 24, 2010, 06:08:58 AM
#10
What put me off-scent was that even with all layers blocked, I was still able to draw entities (lines in this instance) on my latest used layer, even if I could not select them to erase them. If the all layers were lockes, how could I possibly operate on one of them? Strange.

Logged


July 24, 2010, 08:45:40 AM
#11
This locked behavior is exactly how AutoCAD works as well.  (You can draw lines on a locked layer, just not edit.)

On our wishlist is the ability to indicate a Locked Icon when your cursor hovers over a locked layer object, I think this will avoid the confusion. 

thanks.

Logged


* September 10, 2010, 06:09:47 AM
#12
I'm having a similar problem to this in that sporadically I am unable to select objects. I can only fix the problem by closing DoubleCad and restarting it, which is getting a bit frustrating.  A green cross keeps appearing at the same point in my drawing and when I try to draw a construction line it always snaps to this green cross (which isn't anything that I've drawn).
Any ideas?
K

Logged


September 10, 2010, 09:21:21 AM
#13
The little green X is the tracking ppoint. it indicates the last point used in the drawing space.

if you are getting inappropriate snaps, try turning of snap by clicking the SNAP button at the bottom of the screen.

You may also have inadvertantly locked you X or Y coordinates.
Look at the X and Y fields at the bottom of the screen. If there is a check mark in the little x or y box that field and that axis is locked.

Otherwise chances are that you are working with locked layers.

Logged