DoubleCAD XT v5 has released

Recent Posts

Pages: 1 [ 2] 3 4 ... 10
Need Help? Problems - Solutions / Turbocad LTE is deadly slow
« Last post by karimbardee on June 08, 2017, 01:47:14 PM »
Hi there,
Today I installed TC LTE pro 6 and it is very slowly, wait fr 5-10 seconds to refresh the window or open the menu, during this "absence " the cursor disappear.
on the same machine I have turbocad deluxe V20 2D/3D which is suppose to be newer, bigger, accordingly suppose to be heavier on the machine but it works fluently.
also I have TC LTE pro V3 and works fluently !
so the question is why the  newer and the older work without a problem while this one not ?
any idea or suggestion ?
General Announcements / Re: Remove unwanted icons from the Arc toolbar
« Last post by John R on May 26, 2017, 04:21:02 PM »
Open the "Tools / Customize" dialog. While that is open, you can drag the tools you don't need from their current location and drop them within the dialog or anywhere.

You should create a custom Workspace of your new layout. Overwrite the current name in the "Save In" list with a new name, then click on the "Save In" button. You'll now have a custom configuration saved. If you load other configurations, you can always return to your custom layout by selecting it in the "Load From" list and then clicking on the "Load From" button.
That should be it.

See the "Customizing the UI" links in the User Interface page of the Wiki.
See also New Popup Menu and New Popup Toolbar if you wish to create a new Menu or flyout toolbar.
General Announcements / Remove unwanted icons from the Arc toolbar
« Last post by jjl1210 on May 26, 2017, 05:59:59 AM »
I want to clean up my drawing toolbars because I will never use some of the icons so why have them.  Is there a way to remove most of the icons in the arc, line and circle toolbars?  Thanks
General Discussion / Re: Linux/mac?
« Last post by toolmanx1 on April 13, 2017, 03:50:20 AM »
I’m trying to load DoubleCAD on to a Linux machine using Wine. I’m running Ubuntu Serena. According to “Wine —version”  I’m running Wine 2.4  although I loaded amd64 version 1.6.8.  I also loaded both i386 and Wine-Stable. I successfully got setup to load up the DCAD. Wine doublecadxt starts the program. I had problems with it at first erroring out on missing Gecko but I got that fixed. My problem now is the DCAD stops in the middle of the  start up. The error is caused by a dll called “Security_NoProtection.dll”. It jumps to a bad EIP and throws an exception at 0x02B231CD. Since this is a free version of DCAD it is hard for me to see why the people that wrote DCAD put this into the file but it’s there. Now I have to figure out how to jump around it. During setup I used the same SN that I used on my Windows machine. It worked perfectly in Windows. In Linux it accepted it and completed the initial installation. However it never called the request for a key input. I have the key but can’t get it into the DCAD.

DCAD checks somewhere, probably in the registry, to see if the program is active. If the program is active DCAD calls a “Repair or Modify” window instead of the Key request window when setup is run. I’d have an easy fix if I could stop DCAD temporarily from thinking there is a DCAD already installed until I can get the key in. I probably caused this “looking active” since I copied all registry items from my Windows to my Linux. I tried an uninstall but that rarely ever cleans all items up.

By inserting a “jump to” I got to the Tips window but it dies after the tip timer runs out.
I think that the Security.dll is called more than once. If that’s so, I’ll have to jump it at least twice. Any ideas?

I guess we can mark this 'solved'....somewhat.  Although I don't know what caused the problem I have found a working solution.  I copied all the data from the original DCad drawing and pasted it into a blank sheet created from another working DCad drawing.
I saved that as a .dwg and the scale was OK although it still swapped the colors around and I had to change the background back to white.
I guess it must have been some bug in the original DCad V2 drawing.
I'm back in production now.
I had been using DCad V2 for a few years.  All my drawings are in full size 1'=1' and I have made a number of them and then converted them to .dwg format with no problem.
I hadn't used the program for 6 months and I now edited an existing drawing and saved it as a .dwg but it converted the entire drawing scale from feet to inches on the .dwg file.  Initially when I do the "save as" the .dwg shows up correctly but then if I close it and re-open the .dwg it is converted to inches. In other words, a dimension that was 22' on the .2CD file became 1'10" (22") on the .dwg file.  I have tried many different options/trials with the same result.
I tried looking in the forum and I only found one similar problem where another user was having the same trouble with his metric dimensions being converted to inches.  The answer given from the Mod. was that it was being worked on.
So I downloaded V5 today and tried that.  Not good.  Not only was the scale converted to inches on the drawing, the background and drawing colors were reversed (white background to black and black lines were to white).
As I said earlier, I've used DCad for years with great results.  Not sure what changed but is there a workaround to get the .dwg drawing back to the full size (foot-inches) scale and now how to deal with the color changes?
General Discussion / Which software for a novice?
« Last post by Brewster on February 13, 2017, 03:26:02 PM »
Having had some drafting experience back in University (strictly manual) a LONG time ago, what SW would you recommend for doing simple furniture / garden structure design? I have had DoubleCAD XT v3.1 for a long time but have not used it much. I asked this question many years ago but don't recall the reply. I see a free download but it looks like they want my name, rank, serial# & blood type to get it!

I like to do an overall sketch then front, top, right views of the object.

TurboCAD LTE Discussion / Re: Error message when I try to save drawings
« Last post by thebrian on December 05, 2016, 06:36:03 AM »
hmm, with the application closed try right-clicking on the application icon and choosing Run as administrator.

What version of windows are you using? are you running on a network or single machine?
Need Help? Problems - Solutions / Re: DoubleCAD XT v5 post installation cannot run !!
« Last post by Medal on December 02, 2016, 10:44:47 PM »
Ok, I suggest full uninstall, Then run the install "as administrator", then the run the wealthy affiliate application "as administrator" the first time you use it.

Excellent, thanks Brian. I finally got it to work.
TurboCAD LTE Discussion / Error message when I try to save drawings
« Last post by Carl on December 02, 2016, 08:35:16 PM »
This past week, when I attempted saving a drawing, I got an error message, "You do not have permission to save in this location. Contact administrator to obtain permission." Has anyone else run into this. I checked my Microsoft account, and it says I am the administrator, so why would I receive such an error message?
Pages: 1 [2] 3 4 ... 10